UPnP stays disabled, even after trying everything the guide suggests

Topic created ยท 12 Posts ยท 84 Views
  • Hello dear community, I am losing my mind over this problem and I really hope anyone has an idea what I can do, to get my UPnP to enable in WaW (Zombies).

    I tried to play with 2 different friends, which both (after a lot of trial and error) have enabled UPnP, however I don't, even if I do exactly as they did since we were in a Discord call when we tried to set it up. The only thing that worked in the end was me joining them, not the other way around.

    Strangely enough, before I discovered that Plutonium supports T4 now aswell (I first heard about it when only BO2 and MW3 were supported), I tried with one of the friends to play LAN via Radmin and a fixed exe for LAN play, which initially worked, however after trying with Plutonium today even that didn't work anymore.

    So here's what I did:

    • I enabled UPnP in my router's settings, made sure it's activated and saved several times
    • I enabled UPnP in Windows' settings, well actually it was enabled already but I enabled the printer management (?, my PC isn't set to English sorry) aswell to see what happens.
    • I tried manually (re)starting the UPnP service from Windows
    • I forwarded the ports 28960-1 in my router
    • I forwarded them in Windows' firewall
    • I tried turning off my VPN
    • I made sure nothing like Radmin is enabled to alter my network
    • I redownloaded the complete files from the links in the guide
    • I rebooted my PC several times in between changes, also restarted my router

    For one of my friend, it more or less worked out of the box, the other one had to enable UPnP and forward ports, but since we use the same router I could retrace his steps and do it the same way on my own.

    We were just happy to play at some point, however I'm the kind of person that's frustrated over something like this, not that I blame the developers, I rather praise them for supporting this old chunk and giving it so many QoL additions, so yeah, major respect.

    However I still am frustrated that following the guide didn't fix my problem and I really hope some kind soul is maybe even willing to "privately" test it with them, I'm reachable on Discord and I claim my English is understandable, even in voice chat ๐Ÿ™‚

    In any case thanks to everyone who actually did read all this lol

  • Our guide explains that UPnP and port forwarding are not related and not UPnP won't work for everyone.
    Port forward will not enable UPnP and you don't need it anyways, this is unrelated.

    If it doesn't you need to port forward correctly.
    If it still doesn't work then most likely a firewall on your PC is blocking connections.

    Screenshot your port forwarding rule and say what your antivirus is

  • I don't use any antivir aside from Windows' default one.
    Here's the screenshot of the forward settings (for inbound connection, Windows):
    (And my router settings)
    (Sorry that it's not in English)

    Also forgot to mention above that me and my friends tried using that connect command to join each other but it literally does nothing upon hitting enter, neither with /connect.

  • @HalfScoper Plutonium uses the ports 4976-4977.
    Nvm I had manually set net_port to use these dvars in my own settings.

  • When I did port forward in my router I did the range and that didn't work. I had to do each port seperately and that worked fine. Not saying thats your issue but worth a stab in the dark.

  • @MAD_DAD have u tired upnp?
    not sure if waw got the update bo2 got

  • @HalfScoper well first you used IPv6 which isn't reliable/supported in the world so idk if port forwarding works on IPv6 on your router.
    Second you have some weird random ports on IPv4, no clue why.
    Third, since you hide the IP are you 100% sure the IP you selected is the local IP of your computer?

    If you can you should probably use IPv4 instead of IPv6. If you don't know maybe call your ISP and have them help you

  • @Resxt

    1. I didn't use IPv6 on purpose because...

    2. My router had the option to forward ports for both IPv6 and IPv4 at once, so I did. Clicking the yellow exclamation point at IPv4, it says I only have 9580-9599 available as external ports

    3. Yes, I am 100% sure my computer is selected underneath the "censoring"

    However @JezuzLizard I am intrigued on how you achieved that, because I might be able to force those ports to be the ones which are only available for me, might be a solution.

    In any case thanks to everyone already!

  • @hindercanrun said in UPnP stays disabled, even after trying everything the guide suggests:

    @MAD_DAD have u tired upnp?
    not sure if waw got the update bo2 got

    UPnP is disabled in my router and my 2 Plutonium WaW servers and 1 CoD WaW T4 server and 2 IW4x Servers and 1 Cod4x server work just fine


  • Just to show you what i did... here is a selection of my router port forwards.

    They are on my local address as the servers are locally hosted and the ports get forwarded automatically through my external IP

    port forward.png

  • Ok so after a lot of trying and doing research, I came to the conclusion that my ISP didn't assign an IPv4 service to my contract (my router definitely supports it), I only have IPv6 (despite me telling the person I wanna play online games when I ordered it smh), so yeah gotta reach out to them the next days and have to try getting IPv4 to run.

    The solution to play in the meantime is starting T4 in LAN (orange) mode and using something like Radmin (which we used in this case) to connect each other in a private network, one person starts the match, the others open the console and use the connect command together with the assigned IP in Radmin of the person that hosts the match (optionally using sp_minplayers beforehand).

    Thanks again and sorry for bothering y'all with a problem on my end, sigh.

  • This post is deleted!
Log in to reply