Crashing on game launch without error message

Topic created · 4 Posts · 40 Views
  • Crash ID: 4daf4e9ffc8f4622b4f496527032b1c6
    Plutonium.Updater.Core.Models.UpdateException: Failed to update file bin/plutonium-bootstrapper-win32.exe
    ---> System.UnauthorizedAccessException: Access to the file "C:\Users\root\AppData\Local\Plutonium\bin\plutonium-bootstrapper-win32.exe" was denied.
       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access,
       Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize,
       FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath,
       Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
       
       at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access,
       FileShare share, Int32 bufferSize, FileOptions options, String msgPath,
       Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
       
       at System.IO.File.InternalWriteAllBytes(String path, Byte[] bytes, Boolean checkHost)
       at Plutonium.Updater.Core.Updater.<Run>d__23.MoveNext()
    --- End of internal exception stackmonitoring  ---
       at Plutonium.Updater.Core.Updater.<Run>d__23.MoveNext()
    --- End of stacktrace from the previous location where the exception was thrown  ---
       at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at Plutonium.Updater.App.Windows.UpdateWindow.<UpdateWindow_Loaded>d__6.MoveNext()
    

    Steps

    1. PC start

    2. plutonium.exe start from the Download page

    3. T6 start

    4. Firewall warning pops up, Bo2 opens with ingame console title saying "Loading...", the textfield is empty.

    5. Crashes and the funny thing is sometimes my browser crashes too. I have 32 gb ram, the only thing I noticed is that the cpu runs on 100%

    6. I try to start plutonium.exe again but this time it tries to reinstall the "plutonium-bootstrapper-win32.exe" and the
      "plutonium-launcher-win32.exe" again it tried so here is the error message(from the installing window): "Failed to update file bin/plutonium-bootstrapper-win32.exe". This happends even if I restart or reinstall the program.

    7. PC restart, everything back to the first step, with only difference this time it installs the
      "plutonium-bootstrapper-win32.exe" with success.


    Important note

    The bootstrapper file is a bit bugged, probably because its not registered in the windows file manager, because it takes about 2 min until it vanishes (even when I refresh or rename windows thinks the file exists) and when I try to add the file my own it says I don't have the permission.


    What I've tried

    • Reinstall in different orders (after error, before error)
    • Run with admin
    • Click the firewall popup as fast as possible
    • Delete the "plutonium-bootstrapper-win32.exe"
    • Tried to add the "plutonium-bootstrapper-win32.exe" on my own
    • I checked that no program reads or write the bootstrapper file

    Hope I didn't forget anything. I am btw a programmer with 6 years knowlegde and 3 years C++.

  • @Sawey this is most likely caused by your antivirus software falsely flagging the file and moving it to quarantine. Which AV do you use?

  • @Dss0 I have bitdefender, but it showed nothing. Its not that easy to turn it off but this will be the problem. The most obvious thing is the problem as always.

    Thanks

Log in to reply