MW3 Fails To Launch

Topic created · 12 Posts · 89 Views
  • Good day all,

    For context, I have a completely clean and legitimate build of the game. Nothing has been tweaked or modified. Only thing I have done to the game is download the Plutonium Launcher.

    MW3 launches fine, but I get stuck on an infinite loading screen. Occasionally I get the following error:
    "Error connecting to IWServerlist" or something like that.

    Also, this is the infinite loading screen I get stuck on when trying to access the barracks, server list, etc:
    Plutonium Error 2.png

    I attempted to use the console to force a map to load. Doing so gave me this error:
    Plutonium Error 3.png

    Crazy thing is, if I restart my PC and immediately run MW3, I do not run into these issues until I quit the game.

    Is there any fix for these issues? Thanks in advance.

  • @Isolationist looks like a firewall/antivirus issue.
    What antivirus do you have? If you have any extra security tool like MalwareBytes mention it too

  • @Resxt
    Thanks for the response. Tried again today with the same results. I have no antivirus installed except for Windows Defender. I have an exception for the plutonium folder already put in, but not sure what else it could be.

  • @Isolationist the Plutonium folder is not MW3, it's %localappdata%\Plutonium by the way

    Do you have any security tool or proxy or VPN on your PC? Even if it's disabled/disconnected/has Pluto as an exclusion

    It could also be that you changed something in your Windows Defender or that your router is blocking something by default. Check if your router has firewall and if it's set to strict or something similar and change it.

    Also, just a wild guess, but maybe opening the Modern Warfare 3 ports on your router could help

    TCP
    3074 AND 27014-27050

    UDP
    3074 AND 27014-27030

  • Hey there,

    Sorry, forgot to be specific - the exclusion is for the entire Plutonium folder inside Appdata\local. My apologies for not being more specific. I have no other proxys or VPNs.

    I'll double check the router and defender settings. What specifically should I look for? I will try opening the ports you mentioned and will post a response if anything worked. Thank you.

  • @Resxt

    Forgot to include screenshot of current firewall settings:
    allowed_apps_lol.JPG

    Don't know if it helps or not, but I never ran into this trouble with IW4X or any other online multiplayer game.

  • @Isolationist just to be sure maybe you could check the 2 boxes for these apps

    Each router is different so I can't guess what options you have but anything that's referring to a firewall, blocking, rules etc.

    Because if you're sure there is no security software on your PC other than Windows and that you don't have any VPN/proxy installed then what comes to mind is your router blocking something

  • @Isolationist Try disabling Defender with DefenderControl? It might work.

  • @Isolationist I don't recommend disabling Windows Defender completely and it's not needed anyways if you added exclusions.

    An admin just told me your issue means you fail to connect to an Activision server.
    He also reminded me that you could change your DNS. There's a chance that your DNS "block" this server.

    Read this article to change your DNS
    https://www.windowscentral.com/how-change-your-pcs-dns-settings-windows-10

  • @Resxt @ivanovich_

    Tried manually setting DNS to all 3 listed in the article - no change when using all 3, sadly. Firewall was updated as you recommended and still no change. Only thing I haven't been able to do is try port forwarding (my router requires some goofy-ass 3rd party app on a smartphone to set port forwarding)

    Really stumped about my issues here. Again, if I immediately run Plutonium after restarting my PC, I don't run into this issue at all.

  • Well sorry but I ran out of ideas. Could be that your router/ISP has a strict firewall or something idk

  • @Isolationist If you got mobile data, try it that way. If it works, then change your Goddamn router or even ISP, just in case.

Log in to reply