Server cannot be connected to.

Topic created · 9 Posts · 143 Views
  • I am running the server on port 28963, and have portforwarded the port, I start up the server and only I the host can join using my local ip, whereas if I use the public ip , the port is closed and cannot be connect to.
    I think it has to do with the server.bat not opening up the port, because I can host a minecraft server all fine.
    Anyone know what could be the problem?

  • In most network setup you cannot connect to your public IP even if other people can, this is NAT loopback and this is normal.

    The bat file simply uses the port you write.
    If you didn't change the port in the bat and use another port on your router then obviously it won't work.

    Your way of trying is having someone from outside your house/network join your server from the server list or your public IP:port

  • @Resxt srry for the confusion but i meant if an outside user tried joining the server the port seems to be closed. I know about the nat loopback. i'm saying it looks like the game isn't opening the port on its end. I think this explains it,

    "The service or application to which port forwarding is performed must be started so that the port can be seen as 'open' during the check. For example, if the FTP server is not started and even if there is a NAT rule for port forwarding, the port status will be 'closed' during the check."

    Like for minecraft I start up the server, the port opens, but for WAW when I start the server the port is still closed. So i'm sure my portforwarding is not the problem.

  • @themrpotato try different port also allow it in firewall too

  • @chasef7 I tried that with the minecraft port, and still no dice

  • Is there a way someone can give me their working server folder?

  • @themrpotato port checkers are not reliable and iirc don't even work for UDP protocols so don't rely on that.

    There is no issue with your files or the game or whatever it's just a misconfiguration on your side or a firewall blocking something etc.

    Screenshot your bat file (hide the server key)
    Screenshot your port forwarding rule as well
    Also what is your antivirus?

  • @Resxt here are my pics
    e65a40c8-1909-49bb-a3f2-d10d360f8d67-image.png
    554f3575-45e1-4ac6-a271-7ab5ac2b2474-image.png
    ba92d39c-0431-445f-9946-679ddf85d53a-image.png
    208d0b8c-6250-4207-9be9-4acd2c5a19f6-image.png
    I just use windows defender

  • @themrpotato try to add the same port in internal port too in your rule

    Also for this to work you need to open the bat, it's not made for private games, it's a server.

    And last thing you need to let the server open for like 30s until there's a heartbeat for it to be joinable, it's not instant

    If you're sure you only have Windows Defender then add a firewall rule for both incoming and outgoing connections. Also.maybe check both public and private for plutonium-bootstrapper32.exe

    And the most important are you 100% sure the local IPv4 on your port forward rule is the local IPv4 of your PC right now? It could've changed. Open a cmd in Windows and type ipconfig to see

Log in to reply