Voice/mic echoes

Topic created · 4 Posts · 85 Views
  • I just recently downloaded this, and realized that it was echoing both my microphone's input and my friends on Discord. I can confirm it is not a Discord issue, as I muted myself and still heard the echo. I have checked the in-game settings and turned off voice chat, but I still hear the echo. Is there any known way to turn off the input echoing?
    Edit: I can also confirm that it is not a fault of my mic. It does not echo anytime except for when Plutonium BO2 is open.

  • @crispoats I personally haven't had this issue so I don't think I will be much of help. But try setting another sound device as default communication device in sound options and go into Discord setting and chose your mic as the input device through there so the programs won't conflict with each other but if you do this method you might not be able to chat with people in the game and only with discord.

  • After doing some digging around on older posts, I found that one user checked their microphone's settings in Control Panel. Essentially, I found out that if you turn off listening for the device, it gets rid of the echo (and the white noise, which I did not notice until now).

  • @crispoats hope you got every thing sorted out now

Log in to reply