Server uses local ip instead of the public ip

Topic created ยท 23 Posts ยท 75 Views
  • Hello everyone! I just finished doing my zombies server, but i realised that it was imposible to connect to my pubic IP with the commands (connect x.x.x.x:x) but when I try using my local IP it joins, anything that I can do?
    Thanks

  • It's not an issue, it's just how the internet works in certain cases.
    You cannot connect to your own public IP so YOU (only you) need to use localhost instead but others outside of your network use the public IP

  • @Resxt Thank you very much for your early response, but then the problem is that others cannot connect, I have upnp activated and when I open the server It also says: UPnP successfully claimed port x! x=i assigned

  • @Pachi11_ you don't host servers with UPnP.
    You need to port forward the correct port on your router

  • @Resxt I also did port forward but still when it test it in a website it says that it is closed, I tested the port with the server being on so that it uses it, Could you tell me if the configuration of the port is correct? I also did the firewall thing on windows so that it doesnt block the port.
    Thanks!
    imagen_2023-01-14_233544578.png fssf.JPG

  • @Resxt can you reply plsss?

  • @Pachi11_ Yes I can reply just don't expect me to reply within 15 mins at 4AM..

    Forget about port testing websites, they're not reliable.
    Even if everything is working it will show port closed.
    I believe it is because the game uses the UDP protocol and these websites only check for TCP protocol but I'm not sure, just a guess. Anyways they're not reliable, don't use those website, at least for Plutonium.

    The port forward rule is wrong because you need UDP protocol, not TCP.
    Also you need to be 100% sure the Internal IP is your PC's local IPv4 otherwise it won't work. Note that hiding your local IP is useless as this IP only exists on your router, no one from the outside can connect to it.
    As for the port if you did set this port in your bat file then it's fine.

    I'm not sure you should enable DMZ. Could try with it on and off but to my knowledge it's better off, could be wrong here

  • So sorry about the time! It was 2 AM here
    I changed the port protocol to UDP.
    My Internal IP is my PC's IPv4 so there shouln't be any problem there.
    I also checked the bat file to see if I assigned the correct port and it was everything good.
    I desabled DMZ.
    I made sure the key of the server is correct
    But still, people cant join my server or the server doesnt appear in the server list.

    imagen_2023-01-15_151104777.png

  • Like I want the server to appear here imagen_2023-01-15_153534076.png

  • Screenshot your BAT file (hide the server key)

  • imagen_2023-01-15_161115082.png

  • @Pachi11_ so given that you're sure that the server key is T4SP and that the local IPv4 is correct then this looks okay.
    Can you let the server run and give me the name so I can try to join it?

    Also you need to be sure that no firewall or your antivirus firewall is blocking the port

  • server name
    [ARGENTINA] NIGHTCLUB

    I deactivated antivirus and firewall
    Server gives me succesful heartbeats

    Some sus lines the server gives me:
    Opening IP socket: localhost:28963
    UPnP successfully claimed port 28963!
    Hostname: my pc
    IP: 192.168.56.1
    IP: 26.155.59.141
    IP: 192.168.100.43 (this one is my pc's and internal IP)

  • Yeah I can't connect. A firewall might be wrong or the port forward rule might be wrong/not set in the right menu or whatever
    Also if you have a VPN running on your PC you should disable it

    Just to be sure I recommend trying to run the server with vanilla map before going into mods, one thing at a time

  • I put natch der untoten, Is it joinable now?
    Also in a photo I sent there is a port trigger menu which shows me this:
    imagen_2023-01-15_164707844.png

  • @Pachi11_ screenshot the IPv4 port mapping menu
    Also expand WAN LAN and Security on the sidebar and screenshot the sidebar

  • I'm not sure about wan, i cant do anything.
    I've done a static IP in DHCP Static IP menu.
    imagen_2023-01-15_170403665.png imagen_2023-01-15_170440199.png imagen_2023-01-15_170503024.png

  • @Pachi11_ create a windows firewall rule to allow incoming traffic on port 28963 UDP.

  • @Pachi11_ yeah firewall can be important too but it looks like ipv4 port mapping could be the correct menu. Try to create the rule here

  • @Dss0 Thanks for your response! I've already done that
    @Resxt I "forwarded the port" but still no results ๐Ÿ˜‘, I'm going to create a new server key to see if that fixes something...
    I realized that i am not using the same account of the forum and the plutonium launcher, but i don't think that is a problem

    imagen_2023-01-15_173514570.png
    imagen_2023-01-15_173722971.png

Log in to reply