Recommended VPS configuration to avoid lags

Topic created · 19 Posts · 266 Views
  • Hello,

    I started hosting my Bot Warfare server on a VPS using Ubuntu and I got it to work but my issue is that my ping (and the bots ping) is between 70 and 110. Is this because of the VPS poor connection or could this be because of not enough cores on the CPU etc.? I have 0 knowledge about hardware so I'd like to get some advice on this.

    I bought the cheapest package (STD-2) on PulseHeberg
    Do you think the 2GB of RAM and/or 2vCore isn't enough and cause the lags? Would the STD-4 package be enough then? Note that the server is hosted in my country so that's not where the issue comes from.

    Thanks in advance for the help.

  • @lResxt log in via ssh and run the "top" command, it's like task manager on windows and will show you which process uses how much resources. 2g ram and 2vcores should be enough tho.

  • @Dss0 Well I guess this means the CPU is overloaded and I should get the package above? The %CPU value stays around 110/120%
    b283bd91-55c4-4900-b243-2ee0a9af40a2-image.png

  • @lResxt no idea how the server actually performs on linux and if that's normal or not.. i guess you could try getting the bigger package.

  • @Dss0 I tried upgrading but the performance only slightly improved, the ping is now around 60/80 but the freezes in-game are still present so I guess I'll just cancel my purchase. If you or someone else have a recommended website or good configuration to run a server that would be great because I have no idea what would run an IW5 server with normal performance and no freeze I might just keep it on my home connection at this point coz I don't want to spend too much on this anyways

  • @lResxt i ran a iw5 server on an old i3 3240 and it used like 2% cpu so this is pretty strange, ofc we don't know how fast the "vcores" of those servers are, it's also possible they are overprovisioned (meaning too many virtual servers on a dedicated machine). Normally 2 vcores and 2gb ram should be plenty to run a server..
    Ofc it's also possible that this is caused by wine but i have no experience with running cod servers on linux.

  • I still didn't find a website that has what I need with a decent cost so if anyone has a recommendation that would be great. I wanna pay around 4/5$ per month but now I'm scared that Wine would cause performance issues idk

  • @lResxt
    If you want i can host you some servers for a bit while you are searching for it. I have a linux dedicated that virtualize windows on it. I don't use wine, but my friend have is dedicated with wine you can probably talk to him and he can try to helo you with wine issues.

    Discord: DoktorSAS#1141

  • @Sorex Thank you for your help but I'm looking for a long term solution, I don't mind the downtime. Also I don't say I'm having issues with Wine it's just that I wonder why the CPU usage was so high even with a 2vCores CPU that should easily handle an IW5 server and 4gb ram

  • @lResxt said in Recommended VPS configuration to avoid lags:

    I still didn't find a website that has what I need with a decent cost so if anyone has a recommendation that would be great. I wanna pay around 4/5$ per month but now I'm scared that Wine would cause performance issues idk

    which country do you want to host the server in tho?

  • @Dss0 an european country close to Germany

  • @lResxt OVH, hetzner, online.net. In germany there's also netcup (allows to upload your own .iso and boot from it so you could install windows server on it) and contabo.

  • Try the "Windows VC10-4" from Strato. I only had good experiences with the hoster. On 2vCPU and 4GB RAM i can host 6 Pluto/Tekno servers comfortably. And its hosted in the EU for 8€ a month but look out for sales.

    Concering your Performance Problem with Linux, I had a dedicated Server on Hetzner and tried to run MW3 servers there. I tried it with Windows and different Linux distros, always had the same problem you are facing, poor performance and lags.
    I bet it has something to do with the firewalls leading to your game server and back to the client. Just try to change your hoster, rent a small VPS just for a test run.

    You may also try to contact your current hoster and ask him about the performance problems you are experiencing.

  • @SuckOnMyProness said in Recommended VPS configuration to avoid lags:

    I bet it has something to do with the firewalls leading to your game server and back to the client.

    My Hetzner servers are lag free unless someone tries to ddos them and the grace period of the firewalls is still active for the connections.

  • Do you use dedicated servers with a custom hypervisor and VMs or a vps?
    Probably my Xenserver was just badly configured aswell as my VMs. But most of my services were quite responsive, just game servers performed poorly.

  • Dedicated HW only with proxmox and kvm VMs.

  • @Resxt I know it's been a while, friend, but the vps is not the problem, if not the wine, I went through the same thing when using wine, it runs 30% more, the server 34%, almost all the % of the cpu and if the server fills up more, the problem is wine I recommend using windows

  • @VZLAxSmoke Yeah in the meantime I switched to Windows, it just works right away without performance issues.
    I know that there are some people hosting servers (even like 10) on Linux without issues so it might be a matter of Wine version or something like that maybe

  • @Resxt well I was using a vps with 4 ram 4 cores and the truth is that the jerks were ugly and that it was only an sv

    the vps is from a friend who lent me to try and I noticed that the wine was at 80% consuming the cpu the vps is from this page

    https://www.nfoservers.com/

Log in to reply