[ZM] Elasticity V1 - Mod Menu

Topic created · 6 Posts · 992 Views
  • This post is deleted!
  • @lResxt Please edit the the installation instructions to use the proper methods of loading a script mod.

    If you have the raw script it can go into the main_shared folder either matching its path if it is an override(maps/) or loading it as a custom script(scripts/sp).

    We don't recommend users replace their stock files otherwise.

  • @JezuzLizard I searched for hours and didn't find any GSC script so should I just delete the post?

  • @lResxt https://www.se7ensins.com/forums/threads/release-cod®-world-at-war-fastfile-extractor.915654/

    If you get fast file mod menus you can use this tool to dump the scripts.

    https://mega.nz/file/Qogk1ZQS#ITzcGH3iMHQm2VXgSFLGbY2TfQIv7GYW6WOqPAplycc
    I already ripped and searched for all the scripts the mod menu likely modifed. See if it works if you just place them in main_shared/maps.

    If not you'll need to search for the remaining script files based on what functions are missing.

  • @JezuzLizard
    I'm not sure what main_shared/ is so I tried multiple locations including %localappdata%\Plutonium\storage\t4\raw\scripts\sp but none of them seemed to work. The only time I got something to load I got these errors so I'm guessing the scripts aren't properly recognized and cause errors?
    I kept trying with GSC files from other menus with the extractor you sent me and also the files you sent but I didn't get anything to work.

    a1f1d948-df7c-452c-a5d6-a83a2936f7c1-image.png
    c1600261-317a-44c7-8d22-b54dc7d1e2bf-image.png

    The best method I found since I can't get it to work with GSC files is to put the common.ff file in %localappdata%\Plutonium\storage\t4\zone. Is this considered file replacement since it doesn't actually replace a file for the user and can just easily delete it whenever he wants to stop using the mod or is it still not allowed? I think that's a good in-between solution.

    Creating a folder in the mods folder and putting the common.ff file in there works too but since the user has to load the mod which makes it impossible to play any custom map with the menu loaded (unless there's a way to have 2 mods loaded that I don't know but I didn't find anything)

    So what should I do?

    • FF file in the zone folder (no file replacement, works with everything)
    • FF file in a mod folder in the mods folder (no file replacement, only works with base map)
    • Keep digging to make it work with GSC files only (I have no clue if that's even possible)
  • @lResxt Yeah I wasn't really sure that the GSC scripts extracted by themselves would work. At least you figured out a different way to load the modified fastfile that doesn't involve replacing the vanilla files allowing the user to uninstall it if they want to easily.

Log in to reply