Game crashes when friends join Dedicated server

Topic created ยท 6 Posts ยท 101 Views
  • I wanted to set up a server to play private matches with just my group of friends. So I have followed all the instructions in the PlutoT6 Server set-up guide and created a dedicated server.

    I have also configured port forwarding in my router (4976 UDP) and added exceptions in my firewall (BitDefender), although at this point I'm doubtful if it was configured correctly. I did not assign a Static IP address to the PC hosting the server, just wanted to test with Dynamic IP for now.

    When I start the server, I can see it's receiving "getinfo" from some ip addresses so I'm assuming the server is up and running and port forwarding has been configured correctly(maybe?).

    start_server.JPG

    Next, I open t6rmp.exe to check the server browser and I can already see the server I created in the list, so I'm assuming it's working fine so far. To test it out, I try to join the server by connecting to the ip address via t6r console. It starts connecting to server and when it's just about to load the match, the game crashes to the desktop.

    I have tried every solution I can think of and so far everything has failed. I've tried using my laptop to join the server but it's the same result. Putting aside port forwarding, I have tried using Radmin VPN as well but it's the same issue. I have also tried to create custom match through the menu and start the game via console using command "xpartygo" but when someone else tries to join, their game crashes. I can create a custom match with bots and play but if someone tries to join, game crashes for them.

    I feel the issue could be with my port forwarding config. When I check if port is open using canyouseeme.org it's says connection timed out. So as a last resort I decided to post here to figure out if it is actually an issue with my port forwarding or something else.
    If it is an issue with my port forwarding, why wouldn't it work with Radmin VPN?

    Any help would be much appreciated!

  • No replies so far ๐Ÿ˜ž
    Anyone our there who can help with this?

  • Port forwarding looks fine, maybe the issue is that you're running server + game from the same folder.
    Try creating a separate folder for the server, there is also a slimmed down version of the game for use as a server only if you wanna use that (1.9GB).
    T6 Dedicated Server Torrent

  • @Dss0 said in Game crashes when friends join Dedicated server:

    Port forwarding looks fine, maybe the issue is that you're running server + game from the same folder.
    Try creating a separate folder for the server, there is also a slimmed down version of the game for use as a server only if you wanna use that (1.9GB).
    T6 Dedicated Server Torrent

    Running server and game from same folder works dandy for me, but it might be different for him I guess

  • @Dss0 said in Game crashes when friends join Dedicated server:

    there is also a slimmed down version of the game for use as a server only if you wanna use that (1.9G

    Thanks guys. I will try this tonight and get back to you.
    Also, if port forwarding is fine, shouldn't I be getting a success message for this check @ canyouseeme.org? This is what I get,

    canyouseeme.JPG

  • @xylar8910 Thing is the server will use the next free port so if you start the game first it will use 4977 since the game already uses 4976. I recommend setting the port to 4977 in the server start bat and also forwarding that port. Also those port check websites never worked for me, but if you receive "getinfo" packets that means the server is visible on the list.

Log in to reply