IW4M Commands Not Working In Game

Topic created ยท 11 Posts ยท 108 Views
  • I've fully set up my server and IW4M console says its connected and monitoring the server.
    However, when I enter my server and type !owner to claim ownership of the server. Nothing happens. Its like the server is monitoring but not listening to commands.

    Anyone have any ideas why this may be happening? If I need to provide any screenshots let me know, thanks.

  • @KavoGaming have you manually created games_mp.log and set the logpath in the iw4madmin config?

  • path in admin settings.JPG manually created path.JPG

    Yes I think I've done these steps correctly. The admin settings file has two slashes between the location but it doesn't make a difference. I've tried both 2 slashes and 1 now and neither work.

    Any ideas?

  • @KavoGaming You must change this for it to work.

      "RConParserVersion": "Call of Duty Multiplayer - Ship COD_T5_S MP build 7.0.189 CL(1022875) CODPCAB-V64 CEG Wed Nov 02 18:02:23 2011 win-x86",
        
              "EventParserVersion": "Call of Duty Multiplayer - Ship COD_T5_S MP build 7.0.189 CL(1022875) CODPCAB-V64 CEG Wed Nov 02 18:02:23 2011 win-x86",
  • Thanks but where do I put this? anywhere in the Admin setting file? Can I put it anywhere or in a specific place? I'm new to all this!

  • I think I see it now. rcon parser and event parser. Ill try thanks again!

  • @KavoGaming no, you must override it in your config file
    30c23010-f1b1-4fce-9ec9-bedf28dbb96e-image.png

  • ok so change rcon parser and event parser. Ill try it and give an update. I have work rn but I can try in about an hour! thanks for your help!

  • Just tried it there but unfortunately commands still dont work. Thanks for your help though. ๐Ÿ™‚

  • I believe the Parser is working correctly and IW4Admin has no issues.

    When you open the server itself. Verify that Plutonium can Open the log. Right now I'm stuck with this stupid problem but what doesn't make sense is that IW4Admin itself isn't the issue, more so that T5 CANNOT open and write to the log file.

    This is what appears when the server is starting (!start_mp_server.bat):
    d3e494b1-7155-4f05-b542-2a331289779a-image.png

    What I understand that IW4Admin does is READ from what the server WRITES to the log, including chat where it would catch you saying !owner.

  • I see what you mean. Right now I've been advised by the AW4M devs to install Python and setup game logs through that. Im not sure how to do it but Im gona try set it up now. Im hosting my server on a remote PC so this step is only required for people on remote PCs. I will update if it resolves my issue.

Log in to reply