GameOnly Launches if Server Isn't Running

Topic created ยท 8 Posts ยท 115 Views
  • just a small bug report,

    everything works fine, except the game will not launch with the server running. However the server will launch with the game running, so you have to do it in that order for now.

    Im also getting ^3Unknown command "resetCustomGametype" which doesn't seem to affect anything, but I thought I should mention it. I can't find that command anywhere in my config or in any gsc script, so it must be coming from somewhere else I think.

    Thanks!

  • The server will launch when the game is running, however the server will not show up in the list. I guess this has something to do with the server and client being authenticated as 1. I'm not sure but I hope they will fix this soon, as it makes self hosting almost impossible.

  • yes the server will launch with the game running (but not the other way around), however it comes up in the server list for me.
    if its on the same physical pc and you don't see it in the server browser you can still connect to it by typing "connect localhost:portnumber"

  • @Martix
    When server launches after client starts it uses a different port, most likely 4977. You would need to port forward that port.

  • @RaidMax This was the solution! Thanks!

  • @Martix glad you fixed it! ๐Ÿ™‚
    however it doesn't solve the issue from OP, that will need to be handled by the devs. hopefully soon, but it sounds like its not a priority, which makes it impossible unfortunately to join mid game without booting everyone from the round.

    I suspect this has to do with the new anti cheat system, so they can tie an ip to an account, which, fair enough.

  • @thebx2
    Thanks for the workaround!
    Wish this info was in the setup guide I've wasted many hours...

  • @Lupercal happy to help bud! you'll also notice your ping is better ๐Ÿ™‚

Log in to reply