Sending Heartbeat when Loading the Server!

Topic created ยท 9 Posts ยท 200 Views
  • So i have set up my server and customized it and got it all figured out. Only issue is when i run the server bat i get a Sending Heartbeat, and changing map after a few heartbeats like it never goes through. Have there been any fixes to this or any particular reason anyone stumbled accross this?

  • Why do you think sending heartbeats is an issue? Have you thought about what happens to a living creature if its heart stops beating?

    As for the map changes, it is because nobody is playing on the dedicated server. Nothing to worry about.

  • @RektInator ahh, sorry so i have to directly connect to it to experiment and get it the way i want before it will show up under servers? usually, im used to Ips pinging lol so i thought something was wrong. Thanks for clarifying.

  • Oh no, if your server does not show up, either:

    • Your ports are not forwarded.
    • Incoming connections are blocked by a firewall
    • The server is running on 4977 instead of 4976 (this is only the case if you host on a desktop PC, and only happens if you also play the game at the same time).

    Servers should show up directly when running a map.

  • Thank you for the direct answer, I am going to be looking for a fix and keep retrying every step by step. So far on my Win 10 VPS, I have created many inbound and outbound rules to allow port 4976, even a 4976 - 4978 rule. Also allowed the T6R through the firewall, I also disabled firewall completely where every option is Red and suggesting to turn back on. It might even be a VPS error, I was just wondering if I only had this problem. I will definitely try with a different VPS Server.

    Thank you for being quick!

  • When the server is running, try visiting https://canyouseeme.org and test those port numbers. Ensure it can see you.

    If it can't, something that caught me before was that I allowed ports through my Home Profile for the firewall when my network adapter was set to guest profile. Edited guest profile too and it then worked.

  • @Mr-Android said in Sending Heartbeat when Loading the Server!:

    When the server is running, try visiting https://canyouseeme.org and test those port numbers. Ensure it can see you.

    If it can't, something that caught me before was that I allowed ports through my Home Profile for the firewall when my network adapter was set to guest profile. Edited guest profile too and it then worked.

    Except that won't work, since that site can only check TCP ports and Pluto exclusively uses UDP.

    e496fea5-811e-4e49-a7f2-a7a433ba08b1-grafik.png

  • After checking that side, I found out my VPS has a control panel on the actual website that I had to write the inbound and outbound rules. I restarted the VPS a couple of times and now I finally get the code that it is working after sending Heartbeat. Also yes, the canyouseeme website doesn't work to test this. Thank you though, I got it resolved after checking my error on my end. Sorry about this. Thanks for being fast and attempting to help resolve this with me.

  • No worries, glad you're sorted! Thanks for correcting me ๐Ÿ™‚

Log in to reply