Launcher doesn't work

Topic created · 4 Posts · 55 Views
  • I followed everything on the list to download black ops 2 plutonium, however when I get to the launcher it just doesn't work. I have downloaded it and it opens a little screen that starts installing things and it just closes itself. Everytime I open it now it just says 'Fetching Update Info' then closes again and nothing happens. It has never launched the game to the next part of the install tutorial. Im stuck in this infinite loop. I have already made exceptions in windows security for the game and the installer like other posts said. I have already restarted my PC like other posts said. I have deleted and re downloaded installer like other posts said. Yet I am still unable to actually launch the game.

  • I have restarted my PC again and attempted to launch and now my launcher has ceased existence and is not in my downloads or game folder. Just poofed out of existence after trying to run it. This has happened before I got it to the 'Fetching Update Info' part many times.

  • Yes well your AV might've deleted it. Are you sure you don't have any other antivirus besides defender? You do have to add %localappdata%/Plutonium and the pluto launcher to exclusions, here's an example to do so. You can redownload the launcher from here.

  • @HannesC hey, it worked after I uninstalled my other antivirus, I had them disabled but still needed to delete them. After that it worked and I already played a few games seems to be working great now.

Log in to reply