Classic GPUDriverD3D11 issues on Intel HD Graphics 4000 - Noobgamer0111

Topic created · 7 Posts · 28 Views
  • Hello all, u/Noobgamer0111 here!

    I'm trying to get the Plutonium launcher to run.
    However, I am receiving 3 errors for it.

    8714465e-717d-463a-b12a-c67bb871698b-image.png
    f6a6b745-5a00-4509-aab9-17afad4d20b0-image.png
    cf5d7d48-b403-4714-a8aa-dff04809b856-image.png

    I have checked this site's forum posts on this error. I have already run the DirectX Control panel, have checked the force WARP checkbox and have applied and clicked ok.

    My specs: Dell Inspiron 15R 7520 SE (laptop)
    CPU: Intel Core-i7 3612QM @ 2.10GHz (QM = Quad Core, Mobile).
    RAM 2x4GB (8GB total) DDR3 @ 1600MHz
    GPU 1: Intel HD Graphics 4000
    GPU 2: AMD Radeon HD 7730M (2GB, broken due to drivers refusing to install. I have exhausted this issue, this laptop is now 8 years old lol).

    Notes: I can run MW2, IW4x, CoD 4: MW, CoD4x, and MW3 with no issues.
    This laptop GPU can run DirectX 11 and Shader 5.0 games. I don't think it's a fault of DirectX, yet!

    I'm going to keep this post updated with my attempts to solve it.

  • Update: @4:41pm AEDT 25/11/2020
    In the DirectX Control Panel (dxcpl.exe), I replaced the plutonium-bootstrapper.exe path with the launcher.exe from this location: C:\Users[Username]\AppData\Local\Plutonium\bin

    Location of launcher.exe: C:\Users[Username]\AppData\Local\Plutonium\bin\plutonium-launcher-win32.exe

    This is now what I see:
    fcb5a736-b31c-45ff-90ac-5b69303159b9-image.png

    However, I have noticed that the launcher is now quite laggy, with characters loading in after a few seconds after typing them in.
    Jesus Christ, it's now using 72% of my CPU! What de fook?

    d9f9c82d-0187-49e7-b408-06fe8c6fe7c0-image.png

  • Another update: 4:45pm AEDT 25th Nov 2020

    In DirectX Control Panel, added the bootstrapper.exe and the launcher.exe files to the list. Still getting ridiculous amount of CPU usage at 69% (nice).

  • Another update. Dropped DirectX level to 10_0. Still a stupid amount of CPU usage. Can't even login.

  • @Noobgamer0111 you can't login? Intel hd4k is a strange case because it supports dx11 on a hardware level according to intel but the launcher still doesn't work. And yea, cpu usage is gonna be high as all the graphics processing will be done by the cpu with the workaround you're using. Have you tried updating your intel graphics drivers?

  • Hey thanks for the reply @Dss0,

    I was able to login and play for about an hour until I got bored of getting my ass kicked at 250ms. Is this expected behaviour of the bootstrapper/launcher.exe to use such a high amount of the CPU for no real reason?

    On some devices with poor cooling solutions, this can make it very difficult to login, a task that should be very simple.

  • @Noobgamer0111 well i'm guessing it is because the cpu does the launcher's graphics processing in your case (using the workaround) but it is still quite high yes. Don't know what else it could be, it's normal for me (<1%).

Log in to reply