Can't see my own server, and when server and game is up friends can't see it

Topic created · 11 Posts · 91 Views
  • So basically, I got a server running and my friends are able to see and join it with no issues, but when I want to play the game myself I can't open the game while the server is open. I have to open the game first, then open the server. But now there's another problem, my friends just can't see the server anymore, and I can't see the server either, which I was never able to do. Any help?

  • @shAen you forwarded port 4976 but the server will bind to port 4977 when you start the game first so you have to adjust your port forwarding rule. Also yes, you have to start the game first when hosting a server on the same machine, no way around that.
    The fact that other ppl see your servers and you don't is caused by your router not supporting nat loopback.

  • @Dss0 Alright, so I changed the rule so the port is 4977, but what I meant to say is that when I open the game then the server, my friends can't see the server, and neither can I. When I don't open the game at all they can connect and see it fine, but now I can't play with them.

    The video tutorial I watched showed the guy forward with 4977, open the game, then the server, and he was able to see it and connect to it.

    So technically I don't think there's a problem with nat loopback, the problem is how I just described it. I can only reply every 10 minutes so that kind of sucks, but whatever.

  • @shAen you not seeing your own server while other people can (and/or can connect to it via the console using your ip which is also what you can do) is related to nat loopback.
    Well now that you changed it to 4977 it should work? The server console shows which port it binds to when you start it. Also if the server console shows "received ping request from ip" your server is visible on the list for other people. If it only shows heartbeats but no ping requests smth is still wrong with the port forwarding/firewall rules.

  • @Dss0 ok well hold on, if I want the server to be visible AT ALL, I CANNOT have the game open, and as soon as I have both open, the server just does not work. Console shows 4977, forward rule shows 4977.

    Not sure if it's a forward/firewall problem because the server does work, it's just I can't play the game at the same time. It does show heartbeats every once and a while when it's up, and only ping request when someone actually joins the server.

    How would I try to connect using the console?

  • @shAen ye you can, just that you have to always run the game first and server second.
    It should show ping requests all the time because whenever someone refreshes their serverlist all servers get pinged and their info (gametype, slots, map, players....) gets requested.
    You just open the console with the tilde key and type

    connect ip:port
    

    You can either use the lan ip of your pc or your wan ip, so for example 192.168.1.100:4977.
    Can you post a screenshot of your port forwarding settings?

  • @Dss0 I know that's how it should work, it's just not working for me. Idk about the ping thing because it wouldn't give pings for refreshes, but that might've been bad timing? It definitely does give pings for server connections as my friend just did it.

    I'll try that command with both open to see if it works.

    Heres the forward rule;
    Capture.PNG

  • @shAen so your friend can connect to your server? Well everything is in order then.

  • @Dss0 Yes, they can connect, but I couldn't. Figured it out now though, turns out once I do the connect command the server becomes visible on the browser. And turns out once I disconnected and turned the game off the server was still visible and it's connectable.

    My only question is now, can I turn back on the game with no problems, or would I have to restart the server?

  • @shAen the game has a check if another instance of it is running (and a server also counts as an instance) so it prolly won't start. The server does not have that check.

  • @Dss0 alright cool, thank you

Log in to reply