Can't Join Friends

Topic created ยท 26 Posts ยท 283 Views
  • Good evening!

    My friend and I both have UPNP enabled and are on the same internet connection (Laptop and PC), but can't seem to join each other's sessions by double clicking on our names. It just says joining session, then disappears.

    Any solutions?

  • The same thing happened to me yesterday, the only solution we found was to join 1 server online

  • @AFK use the console to manually connect to the host. Open the console with the tilde key and execute

    connect ip
    

    Where the ip is the lan ip of the host, you can get that by opening cmd on the host pc and executing

    ipconfig
    

    The host has to start the match before anyone can connect.

  • @Dss0 Agreed. I'm an old user of Plutonium myself mate. Came back after some time to play again and found the interface has changed for the better and all.

    I tried everything we used to do before to join each other's games. I'm usually the host and we did everything by the book. Xpartygo, connect ip and all.

    But it isn't working. The thing is, my friend and I live in the same building and we have the same router (he doesn't have one) and our public IPs are same. Would this be the issue?

  • @AFK doubt it, if you're on the same lan he should be able to connect to you using your lan ip (192.168.x.x).

    • Try disabling the windows firewall or make a rule to allow incoming traffic for t6 (port 4976 udp)
    • Make sure you can ping his pc (or he yours), open cmd and type
    ping hostip
    

    Where hostip is your lan ip.

  • @Dss0 Ah hell. I was giving him my Public IP like it says in the tutorial. Cheers, mate. I'll check with my LAN IP today and let you know.

    Just another noob question. Shouldn't he be able to join me by Double Clicking my name in the friends list tab in Plutonium?

  • @AFK that probably doesn't work when both players are on the same network.

  • @Dss0 It seems that we can't connect this way either. His LAN IP and mine are different (mine is 106 and his is 104)

    Even though I pinged my phone, him I can't ping his PC. It says Request Timed Out.

    Any suggestions?

  • Some news of progress!

    My friend is able to host a server and I can join in on his ip (.0.104) but when I host, he isn't able to join my session (.0.106).

    What should I do?

  • PS: I can ping him now too as I had to allow some rules. But I can join his game but he can't join mine. Tried disabling the firewall on both PCs as well. No avail, it seems.

  • @AFK well can he ping you? Did you make sure he typed the connect command/ip correctly? Did you start the match before letting him connect?

  • @Dss0 Yes, yes and yes.

  • @AFK no idea then.

  • Weird, tho. I can join his IP but he can't join mine.

    He launches a Custom game and I enter his IP (192.168.0.104) and I instantly join.

    But when I do the same thing he can't join my IP (192.168.0.106).

    Nevertheless, I have created a Server to play on. One problem though. How can I join my own server? When I launch Plutonium, click on Play it just disappears after loading.

    Any ideas?

  • @AFK a dedicated server? If you run server and game on the same pc you always have to start the game first and server second. Connecting works the same way, via ip, just use your own lan ip.
    However if you run the server second it will bind to port 4977 because 4976 is already in use by your game so you have to add that to the ip:

    connect 192.168.0.106:4977
    
  • Hey, presto! It works like a charm!

    Anywho, I used connect 192.168.0.106:4976 on both PCs to connect to my server. Dunno how it works, but it works!

    Thanks so much for your time, @Dss0! God Bless! ๐Ÿ‘ผ ๐Ÿ‘

  • @Dss0 Just one last question. Does my Server Key stay static, i.e when once generated, remains the same forever? Or would I have to generate a new one every time I want to host a server?

  • @AFK nah it stays the same. You only need to generate a new one if you wanna host an additional server. One key per server.

  • Alright. Cheers, mate!

  • @Dss0 Hey, man. It's me again.

    I invited another friend to play with us and he can't join my Custom Game or my server, even though he has both UPnP enabled and ports forwarded.

    Any ideas what to do?

Log in to reply