Problem with port

Topic created ยท 12 Posts ยท 95 Views
  • Hello,

    I tried to follow the pinned about the server set-up guide, everything good, I do have the heartbeat thing going again and again with answer, so it's working. I tried to open ports using my rooter panel. When i'm trying to connect on my own server with localhostl:port its working but nobody of my friends can because its not doing anything, not showing on the server list neither able to connect via the connect myip:port command. I tried to check my port using canyouseeme website where you can check if your port is open but all of them are close and I keep getting "Connection timed out" on them. Do you guys have any idea about the problem ? I may thing it's comming from my router but what could I do ? I'm lost.
    alt text

    Thanks a lot and have a nice day ๐Ÿ˜‰

  • @TooFat4You did you also check your windows firewall when doing the port forwarding you can have it correct but if your windows firewall is not setup right it will stop at your computer

    for windows firewall make sure you do a inbound firewall allow for ports 4976-49xx, xx = where your going to spot the port at

  • Hey @FragsAreUs,
    So yeah, I think I've alrealdy done the windows defender thing, look at my screen It should be the good way.
    Active : Yes, and everything at "all" for port 4976 to 4978
    alt text
    Still doesnt work and I don't really know why. Disabling windows defender doesnt work tho.
    Thanks for your help ๐Ÿ™‚

  • @TooFat4You are you also running a dedi server if so I would set that to port 4977 and have your friends connect to that as its better then doing custom games in my opinion

    then they would need to do connect ip:4977

  • @FragsAreUs I'm running into problem when I want to create a dedicated server but I think it's the same problem when i'm hosting custom games, people can't connect to my ip adress, they try the connect command but nothing happens. Thats why I tried to make one server that could maybe fix the problem !

  • @TooFat4You when you followed the guide for the dedicated server did you ever see port requests with ip's showing in the cmd window

  • @FragsAreUs Here the cmd window. You can see whenever I use "connect localhost:4977", the cmd receive player data but it's not working with my public IP:port for my friends, only the localhost one.
    alt text
    Since my friends and I can't see the server in the server list, we tried to use my public ip.
    If me or my friends try to connect to my public IP:port, they only have the "Joining game session" thing.
    alt texat

    We just tried with one friend if I could start a custom game and then ask him to join with my IP but it's not working, even using RadminVPN (already used when someone else hosted and we all succeed to connect).

    Any idea?

  • @TooFat4You then it looks like your router is having issue's with your port forwarding I would contact your isp over it as for radmin if everything worked it should work just fine as I have had no issues showing people on how to use it

  • @TooFat4You Check if your router has a status page or something that displays the WAN ip, then compare that WAN ip with the ip you see here: https://www.whatsmyip.org/.
    If it shows a different ip you're behind a carrier grade NAT and won't be able to host servers.
    Also set the port to 4977 in your server's startup parameters, it will automatically use the next free port but it's better to assign it manually (your game already uses 4976 or 4977 depending on if you start game or server first).

  • Looks like I do have the same WAN Ip as my IP. I saw that my Apache port (80) worked so I used this one on the server config thing and It did work... Pretty weird imho. Maybe there is something wrong with my rules, I have no idea...
    Well I guess its working so it's okay ๐Ÿ˜›

    Thanks for all the help, and if you have any solutions to use any other port, let me know ^^

  • @TooFat4You said in Problem with port:

    Apache port (80) worked so I used this one on the server config thing and It did work... Pretty weird imho.

    Nah, totally normal and expected.

    Apache needs Port 80 TCP and the game needs UDP.

  • I meant I still had to add the port 80 to my router interface otherwise it won't work.
    Why wouldnt it work for custom port like 4976 etc but works for the port 80 ? I wish all ports that I opened would work instead of only this one!
    Sorry for my bad english btw, hope you guys did understand! ๐Ÿ˜›

Log in to reply