Can't View or Join My Own Zombies Server

Topic created · 12 Posts · 172 Views
  • My friends can join and use my server but I cannot see my server in the server list. So I added my friend and used the friends list to try to join and it said "joining game" (or something like that) and nothing happens afterwards. Any solution for this?

  • @Rezide that can happen if your router doesn't support wan loopback. You should still be able to connect to it via the console.

    connect ip:port
    
  • I have tried it using the console and it still does not connect me to anything after saying "Joining game." I also do not know if my router supports wan loopback, i couldnt find anything on that.

  • @Rezide but your friends can see it on the serverlist? Where is the server hosted? On the same pc you're playing the game on?

  • @Dss0 Yes I am hosting the server on the pc im playing on, on port 4977. This used to work when I played plutonium a couple months ago.

  • @Rezide are you by chance using a rogers modem? I had the same issue after they updated mine and removed the loopback feature. Though telling my friends to connect via IP:port generally works fine

  • @thebx2 It looks like my router/modem also does not use the loopback feature. The thing is, my friends can connect to the server via the server browser, where I cannot see it. I connected to the server using the console and used my local ip. But at the end of the loading screen it says "lost connection to host." Do I need to do something to fix this loopback issue? (I do not have a rogers modem)

  • @Rezide same here, friends can see my server but no one on my own network can. are you on wifi? if so 5ghz or 2.4? I know it shouldn't make a difference but try both anyway if you can

    also be sure you've forwarded port 4976 and whichever port the server binds to

  • @Rezide no, that just causes the inconvenience of not seeing the server in the list but it should work fine besides that. Have you tried connecting using your wan ip? and you did add the port right? so:

    connect xx.xx.xx.xx:4977
    

    And also uh, is this a bo2 server? You posted in the mw3 section.

  • @Dss0 Yes this is a bo2 server, but I may have ran into a potential problem. I port forwarded port 4976 (which i put the server to) but I cannot start the server then open bo2 (because plutonium crashes when I do so). So when I open bo2 and open my server after, it makes my server connect to port 4977 instead of 4967. But I still don't see how this means I cannot connect to my own server. I also tried many other IP's including my Wan IP and nothing works except my local IP.

  • Yeah my main problem now is that when I connect to my server through the console, at the end of the cutscene it says connection lost to host.

  • Have you recently installed a shady game? A few cracked games change your Hosts file located in C:\Windows\System32\drivers\etc which is the first response to a dns lookup call which consol in bo uses for connect regardless of the call using an ip:port
    i use
    connect 192.168.0.10:4977
    but in hosts if i put a line
    192.168.0.11 192.168.0.10

    it changes my commands to refer the seconds instance to the first instance which will just hang
    check that you hosts file has not set a localhost to a specific ip unless your connected to your local network with that ip

Log in to reply